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How to Use this Guide

Ascential DataStage™ is a powerful software suite that is used to 

develop and run DataStage jobs. A DataStage job can extract from 

different sources, and then cleanse, integrate, and transform the data 

according to your requirements. The clean data is ready to be 

imported into a data warehouse for analysis and processing by 

business information software. 

This manual describes the DataStage Director, the DataStage 

component that is used to validate, schedule, run, and monitor 

DataStage server jobs and parallel jobs. For information about how to 

perform these tasks for DataStage mainframe jobs, refer to the 

documentation supplied with the mainframe computer. (For a brief 

explanation of server, parallel, and mainframe jobs, refer to 

"DataStage Projects and Jobs" on page 1-3.) 

To use this manual you should be familiar with the Windows 2000 or 

Windows XP interface, but no other special skills or knowledge are 

required.

To find particular topics you can:

Use the Guide’s contents list (at the beginning of the Guide).

Use the Guide’s index (at the end of the Guide).

Use the Adobe Acrobat Reader bookmarks.

Use the Adobe Acrobat Reader search facility (select Edit ➤ 
Search).

The guide contains links both to other topics within the guide, and to 

other guides in the DataStage manual set. The links are shown in blue. 

Note that, if you follow a link to another manual, you will jump to that 

manual and lose your place in this manual. Such links are shown in 

italics.
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Organization of This Manual How to Use this Guide
Organization of This Manual
This manual contains the following:

Chapter 1 contains an overview of DataStage® and its component 
parts.

Chapter 2 describes the DataStage Director and how to use it.

Chapter 3 covers how to validate, run, delete, schedule, and 
administer DataStage server jobs.

Chapter 4 describes job batches.

Chapter 5 describes how to monitor a running server job.

Chapter 6 describes the job log file and the Job Log view.

The Glossary defines terms that have specific meaning in 
DataStage. 

Documentation Conventions
This manual uses the following conventions: 

Convention Usage

Bold In syntax, bold indicates commands, function names, keywords, 
and options that must be input exactly as shown. In text, bold 
indicates keys to press, function names, and menu selections.

UPPERCASE In syntax, uppercase indicates BASIC statements and functions 
and SQL statements and keywords.

Italic In syntax, italic indicates information that you supply. In text, 
italic also indicates UNIX commands and options, file names, 
and pathnames.

Plain In text, plain indicates Windows commands and options, file 
names, and path names.

Lucida 
Typewriter

The Lucida Typewriter font indicates examples of source code 
and system output.

Lucida 
Typewriter

In examples, Lucida Typewriter bold indicates characters that 
the user types or keys the user presses (for example, 
<Return>).

[ ] Brackets enclose optional items. Do not type the brackets unless 
indicated.

{ } Braces enclose nonoptional items from which you must select 
at least one. Do not type the braces.
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How to Use this Guide DataStage Documentation
DataStage Documentation
DataStage documentation includes the following:

DataStage Director Guide: This guide describes the DataStage 
Director and how to validate, schedule, run, and monitor 
DataStage server jobs.

DataStage Manager Guide: This guide describes the DataStage 
Manager and describes how to use and maintain the DataStage 
Repository.

DataStage Designer Guide: This guide describes the DataStage 
Designer, and gives a general description of how to create, design, 
and develop a DataStage application. 

DataStage Server: Server Job Developer’s Guide: This guide 
describes the tools that are used in building a server job, and it 
supplies programmer’s reference information.

DataStage Enterprise Edition: Parallel Job Developer’s 
Guide: This guide describes the tools that are used in building a 
parallel job, and it supplies programmer’s reference information.

DataStage Enterprise Edition: Parallel Job Advanced 
Developer’s Guide: This guide gives more specialized 
information about parallel job design.

DataStage Enterprise MVS Edition: Mainframe Job 
Developer’s Guide: This guide describes the tools that are used 
in building a mainframe job, and it supplies programmer’s 
reference information.

DataStage Administrator Guide: This guide describes 
DataStage setup, routine housekeeping, and administration.

itemA | itemB A vertical bar separating items indicates that you can choose 
only one item. Do not type the vertical bar.

... Three periods indicate that more of the same type of item can 
optionally follow.

➤ A right arrow between menu commands indicates you should 
choose each command in sequence. For example, “Choose File 
➤ Exit” means you should choose File from the menu bar, 
then choose Exit from the File pull-down menu.

This line 
➥ continues

The continuation character is used in source code examples to 
indicate a line that is too long to fit on the page, but must be 
entered as a single line on screen.

Convention Usage
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DataStage Documentation How to Use this Guide
DataStage Install and Upgrade Guide. This guide contains 
instructions for installing DataStage on Windows and UNIX 
platforms, and for upgrading existing installations of DataStage.

DataStage NLS Guide. This Guide contains information about 
using the NLS features that are available in DataStage when NLS 
is installed.

These guides are also available online in PDF format. You can read 

them using the Adobe Acrobat Reader supplied with DataStage. See 

Install and Upgrade Guide for details on installing the manuals and 

the Adobe Acrobat Reader.

You can use the Acrobat search facilities to search the whole 

DataStage document set. To use this feature, select Edit ➤ Search 

then choose the All PDF documents in option and specify the 

DataStage docs directory (by default this is C:\Program 

Files\Ascential\DataStage\Docs).

Extensive online help is also supplied. This is particularly useful when 

you have become familiar with DataStage, and need to look up 

specific information.
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1
Introducing DataStage

Many organizations want to make better use of their data. But that 

data may be stored in different formats in different types of database. 

Some data sources may be dormant archives, others may be busy 

operational databases. Extracting and cleaning data from these varied 

sources has always been time-consuming and costly – until now. 

DataStage makes it simple to design and develop efficient 

applications that make data warehousing a reality where it was 

impossible before.

What Is a Data Warehouse?
A data warehouse is a central database containing copies of data from 

all the operational sources and archive systems in an organization. 

But the database does not have to be large. Instead of storing details 

of every transaction, order, or set of sales figures, the data warehouse 

stores totals, averages, area figures, and so on. This data is structured 

to make it easy to query and to generate reports. 

Inside the data warehouse you can perform analyses that would be 

impractical on a working database. This means that anyone who 

needs access to the data gets all the information they want, and only 

the information they want. The data warehouse can be created or 

updated at any time, with minimum disruption to working systems. 

Why Do I Need One? 
Working databases are busy. It is hard to gain an accurate picture of 

the contents of the database at any time because it changes 
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What Does DataStage Do? Introducing DataStage
frequently. By transferring working data into a data warehouse, you 

can take snapshots of what is going on. Also, working databases 

contain dirty data – records in different formats, with key values 

missing or out of range, and so on. In a fast-moving working database 

it is difficult to trap mistakes or incomplete entries. Using DataStage, 

you can cleanse data before loading it into a data warehouse, 

ensuring that your business decisions are based only on valid 

information. 

As well as a working database, you may have archive systems or 

incompatible data sources that you have inherited. These may be 

static, but inaccessible because their format is different from your 

working system. You can use DataStage to transform this data into 

compatible formats that can be stored in the data warehouse.

What Does DataStage Do?
DataStage comes in between your data and your data warehouse. 

DataStage jobs process the data to meet your needs, including:

Extraction – DataStage takes data from indexed files, sequential 
files, networked databases, archives, and external data sources 
and stores it in the data warehouse.

Aggregation – DataStage takes your working data, calculates 
totals and averages, then stores it in the data warehouse. This 
means you have to store much less data, which is quicker and 
easier to access.

Transformation – DataStage converts inconsistent data into the 
required format and loads it into the data warehouse.

How Is DataStage Packaged? 
DataStage is client/server software. The server holds the data while it 

is being processed. The client is the interface to DataStage that is used 

for designing and running jobs, or managing the data in the 

Repository. The client components include:

DataStage Designer, for creating DataStage server and 
mainframe jobs. Server jobs are compiled into executable 
programs that are scheduled by the DataStage Director and run by 
the DataStage Server. Mainframe jobs are downloaded from the 
Designer to mainframe computers, where they are compiled and 
run by mainframe tools.

DataStage Director, for running DataStage server jobs. 
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Introducing DataStage DataStage Projects and Jobs
DataStage Manager, for viewing and editing the contents of the 
Repository.

DataStage Administrator, for administering DataStage projects 
and conducting housekeeping on the server. 

The client and server components installed depend on the edition of 

DataStage you have purchased. DataStage is packaged in two ways:

Developer’s Edition, used by developers to design, develop, 
and create executable DataStage jobs. The Developer’s Edition 
contains all the client components described earlier and the 
server. The developer’s role, DataStage Designer, and DataStage 
Manager are described in DataStage Designer Guide and 
DataStage Manager Guide.

Operator’s Edition, used by operators to validate, schedule, run, 
and monitor DataStage jobs that have been developed elsewhere. 
The Operator’s Edition contains DataStage Director, DataStage 
Administrator, and DataStage Server components only. 

DataStage Projects and Jobs
You always enter DataStage through a DataStage project. When you 

start a DataStage client you are prompted to attach to a project. Each 

project contains DataStage jobs and the components required to 

develop or run them.

DataStage jobs are made up of individual stages. A stage represents a 

data source or a process. For example, one stage may extract data 

from a data source, while another transforms it. The data required at 

each stage and how it is handled is specified in the job design. When 

the job is run, the processing described in the job design is 

performed. Variable parameters such as file names, dates, and so on, 

can be specified when the job is run. DataStage jobs can be exported 

for use on other DataStage systems.

DataStage supports three types of job:

Server jobs are both developed and compiled using DataStage 
client tools. Compilation of a server job creates an executable that 
is scheduled and run from the DataStage Director.

Parallel jobs. These are compiled and run on the DataStage 
server in a similar way to server jobs, but support parallel 
processing on SMP, MPP, and cluster systems.

Mainframe jobs are developed using the same DataStage client 
tools as for server jobs, but compilation and execution occur on a 
mainframe computer. The DataStage Designer generates a 
COBOL source file and supporting JCL script, then lets you upload 
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them to the target mainframe computer. The job is compiled and 
run on the mainframe computer under the control of native 
mainframe software.

There are also:

Job Sequences. A job sequence allows you to specify a 
sequence of DataStage jobs to be executed, and actions to take 
depending on results.
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The DataStage Director

The DataStage Director is the client component that validates, runs, 

schedules, and monitors jobs run by the DataStage Server. It is the 

starting point for most of the tasks a DataStage operator needs to do 

in respect of DataStage jobs.

Note DataStage mainframe jobs run on a mainframe computer, 

and use mainframe-specific tools. These jobs are not visible 

in the DataStage Director. In this manual the term job 

therefore refers to DataStage server and parallel jobs only. 

For information about running DataStage mainframe jobs, 

consult the documentation supplied with your mainframe 

software.

This chapter describes the interface to the DataStage Director and 

how to use it, including:

Starting the DataStage Director

Using the DataStage Director window

Finding text in the DataStage Director window, sorting data, and 
printing out the display

Setting options and defaults for the DataStage Director window 
and for jobs you want to run

Switching between projects and exiting the DataStage Director

Starting the DataStage Director
To start the DataStage Director:
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1 Choose Start ➤ Programs ➤ Ascential DataStage ➤ 
DataStage Director, or choose the appropriate program folder if 
you installed DataStage elsewhere. The Attach to Project dialog 
box appears:

2 Enter the name of your host in the Host system field. This is the 
name of the system where the DataStage Server is installed.

3 Enter your user name in the User name field. This is your user 
name on the server system.

4 Enter your password in the Password field. If you are connecting 
to a Windows server via LAN Manager, you can select the Omit 
check box. The User name and Password fields gray out and you 
log on to the server using your current Windows account details. 

Warning Think carefully before using the Omit option to log 

on to DataStage. If you use this option, note that:

– You cannot specify UNC pathnames in DataStage clients.

– You must specify the host name in uppercase.

– You cannot access remote files.

– You may get errors if you import meta data from an ODBC data 
source if you are not logged on to the same domain as the 
server.

5 Enter the name of the project you want to use or choose one from 
the Project list, which displays all the projects installed on the 
server. 

6 Click OK. The DataStage Director window appears.

Note You can also start the DataStage Director from the 

DataStage Designer or the DataStage Manager by 

choosing Tools ➤ Run Director. You are automatically 

attached to the same project and you do not see the 

Attach to Project dialog box. For more information 

about the DataStage Designer and Manager, see 
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DataStage Designer Guide and DataStage Manager 

Guide.

The DataStage Director Window
The DataStage Director window appears when you start the Director:

This section describes the features of the DataStage Director window 

including:

The job category pane

The display area

The menu bar

The toolbar

The status bar

Job Category Pane
The left pane of the DataStage Director window is the job category 

pane. It displays the job category tree, which lists job categories and 

subcategories that contain server jobs. The jobs in the currently 

selected category are listed in the display area. You can hide the job 

category pane by choosing View ➤ Show Categories.

Display Area
The display area is the main part of the DataStage Director window. 

There are three views: 

Job Status. The default view, which appears in the right pane of 
the DataStage Director window. It displays the status of all jobs in 
the category currently selected in the job category tree. If you hide 
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the job category pane, the Job Status view includes a Category 
column, and displays the status of all server jobs in the current 
project, regardless of their category. See "Job Status View" on 
page 2-6 for more information.

Job Schedule. Displays a summary of scheduled jobs and 
batches in the currently selected job category. If the job category 
pane is hidden, the display area shows all scheduled jobs and 
batches, regardless of their category. See Chapter 3, "Running 
DataStage Jobs," for a description of this view. To switch to the 
Job Schedule view, choose View ➤ Schedule, or click the 
Schedule button on the toolbar. 

Job Log. Displays the log file for a job chosen from the Job 
Status view or the Job Schedule view. The job category pane is 
always hidden. See Chapter 6, "The Job Log File," for more details. 
To switch to this view, choose View ➤ Log, or click the Log 
button on the toolbar.

Updating the Display

You can set how often the display area is updated from the server by 

editing the Director options. For more information, see "Director 

Options" on page 2-17. 

You can also update the screen immediately by doing one of the 

following:

Choose View ➤ Refresh. 

Choose Refresh from the shortcut menus (see "Shortcut Menus" 
on page 2-8 for more details).

Press Ctrl-R.

Each entry in the display area represents a job, scheduled job, or 

event in the job log, depending on the current view. An icon is 

displayed by default for each entry. To hide the icons, choose Tools ➤ 

Options ➤ View.

Note You can increase the refresh rate by organizing jobs within 

job categories, so that you do not display more jobs than 

necessary in the display area. For information about how to 

organize jobs within categories, refer to DataStage Designer 

Guide.

Menu Bar
The menu bar has six pull-down menus that give access to all the 

functions of the Director:

Project. Opens an alternative project and sets up printing.
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View. Displays or hides the toolbar, status bar, buttons, or job 
category pane, specifies the sorting order, changes the view, 
filters entries, shows further details of entries, and refreshes the 
screen. 

Search. Starts a text search dialog box. 

Job. Validates, runs, schedules, stops, and resets jobs, purges old 
entries from the job log file, deletes unwanted jobs, cleans up job 
resources (if the administrator has enabled this option), and 
allows you to set default job parameter values.

Tools. Monitors running jobs, manages job batches, and starts 
the DataStage Designer and DataStage Manager. It also starts 
MetaStage Explorer and Quality Manager, if these components 
are installed on the system, and custom software. If you are 
running parallel jobs on a UNIX server, allows you to manage data 
sets (see "Managing Data Sets" in Parallel Job Developer’s Guide 
for details).

Help. Invokes the Help system. You can also get help from any 
screen or dialog box in the DataStage Director.

Toolbar
The toolbar gives quick access to the main functions of the DataStage 

Director. 

The toolbar is displayed by default, but can be hidden by choosing 

View ➤ Toolbar or by changing the Director options. See 
"Director Options" on page 2-17 for more details. To display 

ToolTips, let the cursor rest on a button in the toolbar. 

Status Bar
The status bar appears at the bottom of the DataStage Director 

window and displays the following information:

The name of a job (if you are displaying the Job Log view).

Job Run aJob

Find

Sort - Reset a

Help

Reschedule
a Job

Open
JobJobAscendingLogStatusProject

Schedule
a Job

Stop a
Job

Print
View

Job
Schedule

Sort -
Descending
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The number of entries in the display. If you look at the Job Status 
or Job Schedule view and use the Filter Entries… command, this 
panel specifies the number of lines that meet the filter criteria. If 
you have set a filter then (filtered) or (limited) is displayed.

The date and time on the DataStage server.

Note Under certain circumstances, the number of entries in the 

display is replaced by the last error message issued by the 

server. The message disappears when the screen is 

refreshed. 

Job Status View
The Job Status view is the default view displayed when you start the 

DataStage Director (see "The DataStage Director Window" on 

page 2-3). You can change the default view by editing the Director 

options (see "Director Options" on page 2-17 for more details). You 

can also filter the jobs displayed in the view (see "Filtering the Job 

Status or Job Schedule View" on page 2-11).

The Job Status view shows the status of all the jobs in the currently 

selected job category, or, if the job category pane is hidden, in the 

current project. The view has the following columns:

Column Description

Job name The name of the job.

Status The status of the job. See "Job States" for the 
possible job states and what they mean.

Started On date The time and date a job was started. These fields are 
only filled in for a job with a status of Running.

Last ran On date The time and date the job was finished, stopped, or 
aborted. These columns are blank for jobs that have 
never been run.

Description A description of the job, if available.
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Job States
The Status column in the Job Status view displays the current status 

of the job. The possible job states are as follows: 

Job Status Details
To view more details about a job’s status, select it in the display and 

do one of the following:

Choose View ➤ Detail.

Right-click to display the shortcut menu and choose Detail.

Double-click the job in the display. 

The Job Status Detail dialog box appears:

Job State Description

Compiled The job has been compiled but has not been validated or 
run since compilation.

Not compiled The job is under development and has not been compiled 
successfully.

Running The job is currently being run, reset, or validated.

Finished The job has finished.

Finished (see log) The job has finished but warning messages were 
generated or rows were rejected. View the log file for 
more details.

Stopped The job was stopped by the operator.

Aborted The job finished prematurely. 

Validated OK The job has been validated with no errors.

Validated (see log) The job has been validated but warning messages were 
generated or rows were rejected. View the log file for 
more details.

Failed validation The job has been validated, but an error was found.

Has been reset The job has been reset with no errors.
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This dialog box contains details of the selected job’s status:

Use Copy to copy the whole window or selected text to the Clipboard 

for use elsewhere. 

Click Next or Previous to display status details for the next or 

previous job in the list. 

Click Close to close the dialog box. 

Shortcut Menus
DataStage has shortcut menus that appear when you right-click in the 

display area or job category pane. The menu you see depends on the 

view or window you are using, and what is highlighted in the window 

when you click the mouse. 

This field… Contains this information…

Project The name of the project and the DataStage server.

Status The current status of the chosen job.

Wave # An internal number used by DataStage when the job is run.

Job name The name of the job.

Started at The date and time the job was started. This field is used only for a 
job with a status of Running.

Last run at The date and time the job was last run.

Description A description of the job. This is the description entered by the 
developer when the job was created. If the job has job parameters, 
this column also displays the values used in the run.
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Shortcut Menus in the Job Status View
This Job menu appears when you right-click on a selected job in the 

Job Status view. If you right-click in the display area when the cursor 

is not over a job, a subset of this menu appears. From the Job menu 

you can:

Add the job to the schedule

Start a Monitor window (available only if an entry is selected)

Set job parameter defaults

Display the Job Schedule or Job Log view

Use Find to search for text in the display area

Filter (limit) the jobs listed in the display area

Refresh the display

Display details of a log entry (available only if an entry is selected)

Delete the selected job

Shortcut Menus in the Job Log View
This menu appears when you right-click on an entry in the Job Log 

view. If you right-click in the display area when the cursor is not over a 

log entry, a subset of this menu appears. From the full menu you can:

Start a Monitor window (available only if a log entry is selected)

Set job parameter defaults

Display the Job Status or Job Schedule view

Use Find to search for text in the display area

Filter (limit) log entries

Refresh the display

Display details of a log entry (available only if a log entry is 
selected)

Jump to the batch log from a job within a batch

Delete an entry.
Director Guide 2-9



Shortcut Menus The DataStage Director
Shortcut Menus in the Job Schedule View
This Job menu appears when you right-click on a job in the Job 

Schedule view. If you right-click in the display area when the cursor is 

not over a job, a subset of this menu appears. From the Job menu you 

can:

Schedule, reschedule, or unschedule the selected job

Set job parameter defaults

Display the Job Status or Job Log view

Use Find to search for text in the display area

Filter (limit) the jobs listed in the display area

Refresh the display

Display details of an entry in the Job Schedule view (available 
only if an entry is selected).

Delete an entry.

Shortcut Menus in the Job Category Pane
When you right-click in the job category pane, this menu appears, 

from which you can:

Filter (limit) the jobs listed in the display area

Refresh the job category pan

Shortcut Menu in the Monitor Window
This menu appears when you right-click in the Monitor window 

(described in Chapter 5). From this menu you can:

Refresh the display

Display details of a selected stage

Show link information in the Monitor window

Show CPU usage in the Monitor window

Clean up job resources

Save or clear the Monitor window settings 

Display information about the DataStage release
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Filtering the Job Status or Job Schedule View
By default, the Job Status view or Job Schedule view displays 

information about all the jobs in the currently selected job category. If 

you hide the job category pane, the view displays information about 

all the jobs in a project. On a large project, the display may include 

more information than you need. If you want to focus on specific 

types of job, based either on their name or their status, you can filter 

the view so that it displays only those jobs.

To filter the jobs in the Job Status view or the Job Schedule view:

1 If the view you want to filter is not already displayed, choose View 
➤ Status or View ➤ Schedule, as appropriate.

2 Start the Filter facility by doing one of the following:

– Choose View ➤ Filter Entries… from the menu bar.

– Choose Filter… from the shortcut menu.

– Press Ctrl-T.

The Filter Jobs dialog box appears:

3 Choose which jobs to include in the view by clicking either the All 
jobs or Jobs matching option button in the Include area. 

If you select Jobs matching, enter a string in the Jobs 
matching field. Only jobs that match this string will be displayed. 

The string can include wildcards, character lists, and character 

ranges.

Wildcard/Pattern Description

? Matches any single character.

* Matches zero or more characters.
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4 Choose which jobs to exclude from the view by clicking either the 
No jobs or Jobs matching option button in the Include area. If 
you select Jobs matching, enter a string in the Jobs matching 
field. Only jobs that match this string will be excluded. The string 
definition is the same as in step 3.

5 Specify the status of the jobs you want to display by clicking an 
option button in the Job status area.

– All lists jobs that have any status.

– All, except “Not compiled” lists jobs with any status except 
Not compiled.

– Terminated normally lists jobs with a status of Finished, 
Validated, Compiled, or Has been reset.

– Terminated abnormally lists jobs with a status of Aborted, 
Stopped, Failed validation, Finished (see log), or Validated (see 
log).

6 If you want to restrict the display to released jobs, select the 
Include only released jobs check box in the Released jobs 
area.

7 Click OK to activate the filter. The updated view displays the jobs 
that meet the filter criteria. The status bar indicates that the entries 
have been filtered.

Examples of Filtering by Job Name
The following examples show how to use the Jobs Matching field in 

the Filter Jobs dialog box to filter the Job Status view or the Job 

Schedule view.

# Matches a single digit.

[charlist] Matches any single character in charlist.

[!charlist] Matches any single character not in charlist.

[a–z] Matches any single character in the range a–z.

Wildcard/Pattern Description
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Example 1

Example 2

Continuing Example 1, if you also specify *input as an “Exclude” 

filter, the Job Status view shows only job2output.

Example 3

Finding Text
If there are many entries in the display area, you can use Find to 

search for a particular job or event. You start Find in one of three 

ways:

Choose Search ➤ Find… .

Choose Find… from the shortcut menu.

Click the Find button on the toolbar.

The Find dialog box appears:

Job Names “Include” Filter Job View

job2input job2* job2input

job2output job2output

job3input

job3output

Job Names “Include” Filter Job View

A3tires [A-E]3* A3tires

A3valves A3valves

B3tires B3tires

B3valves B3valves

F3tires

F3valves
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The Look in field shows the currently selected job category. If the job 

category pane is hidden, and the display area lists jobs from all job 

categories, the Look in field specifies All Categories. You cannot edit 

this field.

To use Find:

1 Enter text in the Find what field. This could be a date, time, 
status, or the name of a job. 

Note If the text entered matches any portion of the text in any 

column, this constitutes a match. 

2 If the displayed entry must match the case of the text you entered, 
select the Match Case check box. The default setting is cleared.

3 Choose the search direction by clicking the Up or Down option 
button. The default setting is Down.

4 Click Find Next. The display columns are searched to find the 
entered text. The first occurrence of the text is highlighted in the 
display. The text can appear in any column or row of the display 
area.

5 Click Find Next again to search for the next occurrence of the text. 

6 Click Cancel to close the Find dialog box.

Note You can also use Search ➤ Find Next to search for an 

entry in the display. If there is a search string in the Find 

dialog box, Find Next acts in the same way as the Find 
Next button on the Find dialog box. If there is no 

search string in the Find dialog box, this option displays 

the Find dialog box where you must enter a search 

string. 
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Sorting Columns
You can organize the entries in the display area by sorting the 

columns in ascending or descending order. The column currently 

being used for sorting is indicated by a symbol in the column title: 

> indicates the sort is in ascending order. 

< indicates the sort is in descending order.

To sort a column do any one of the following:

Click the column title. This selects the column for sorting toggles 
between ascending and descending. 

Click the Ascending or Descending button on the toolbar.

Choose View ➤ Ascending or View ➤ Descending.

If you choose a column that contains a date or a time, both the date 

and time columns are sorted together. 

Printing the Current View
You can print information from the current view. The content of the 

printout depends on the view you are using and the options you 

choose in the Print dialog box. To print the current view:

1 Do one of the following to display the Print dialog box:

– Choose Project ➤ Print… .

– Click the Print button on the toolbar.

This dialog box contains the name of the printer to use. By default, 

this is the default Windows printer. For information on how to 

specify an alternative printer, see "Changing the Printer Setup" on 

page 2-17.
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2 Choose the range of items to print by clicking an appropriate 
option button in the Range area:

– All entries prints all entries in the current view.

– Current page prints all entries visible in the display area for 
the current view. 

– Current item prints the selected item only.

3 Choose what to print by clicking an appropriate option button in 
the Print what area:

– Summary only prints a summary for each item.

– Full details prints detailed information for each item.

4 Specify the print quality to use by choosing an appropriate setting 
from the Print quality list:

– High (the default setting)

– Medium

– Low

– Draft

Note This setting is ignored if Print to file is selected.

5 Select the Print to file check box if you want to print to a file only. 

6 Click OK. If you are printing to file, the Print to file dialog box 
appears. Enter the name of a text file to use. The default is 
DSDirect.txt  in the Program Files\Ascential\DataStage directory.

What Is in the Printout?
The content of the printout depends on the view you are using:

For the Job Status view, the printout contains the current status 
for each job in the project, and the date and time the job was last 
run. 

For the Job Schedule view, the printout contains an entry for each 
scheduled job in the project specifying when the job is scheduled 
to run. 

For the Job Log view, the printout can include information about 
each event in the job log file. For more information about the job 
log file, see Chapter 6. 
2-16 Director Guide



The DataStage Director Director Options
Changing the Printer Setup
Printouts from the Director are normally output to the default 

Windows printer. To choose an alternative printer or specify other 

printer settings:

1 Choose Project ➤ Print Setup… . The Print Setup dialog box 
appears. (This dialog box is also displayed if you click Setup… in 
the Print dialog box.)

2 Change any of the settings as required or choose a different 
printer. 

3 Click OK to save the settings and close the dialog box. 

Director Options
When you start the DataStage Director, the current settings for the 

Director options determine what is displayed in the DataStage 

Director window. The settings include:

The DataStage Director window position and size 

The time interval between updates from the server

The number of data rows processed before a job is stopped (only 
applies to server jobs)

The number of unexpected warnings that are permitted before a 
job is aborted

Whether the toolbar, status bar, or icons are displayed 

The filter criteria

The process priority level for the DataStage Director
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You can modify the settings for the Director options by choosing 

Tools ➤ Options… . The Options dialog box appears: 

The five pages in the dialog box are described in the following 

sections.

General Page 
From the General page you can:

Enable/Disable automatic server update

Change the server update interval

Compare the client and server times 

Save window settings

The Server Update Interval

The Refresh Interval (seconds) is the time, in seconds, between 

updates from the server. Click the arrow buttons to increase or 

decrease the value in the box. The default setting is 600. 

Note that if you choose a long refresh time, the status displayed in the 

DataStage Director window may not represent what is happening on 

the server. For example, if you start a run, the job status may not 

update to Running until a whole refresh interval has elapsed. 

Conversely, if you choose a refresh time that is too short, the 

DataStage Director requests information from the server at a rate that 

is too frequent and unproductive. You must find a value between 

these extremes that meets your update requirements. 
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If you have a large project, you may wish to disable automatic refresh 

altogether by clearing the Enabled check box. You can refresh 

manually using View ➤ Refresh.

Comparing Client and Server Times

If you select the Compare client and server system times check 

box, when the Director first attaches to a project, it checks that the 

system times on the client and the server are within five minutes of 

each other. If they are not, a warning message appears. This check box 

is selected by default.

Saving Window Settings

The Save on exit area contains two check boxes that determine the 

settings that are saved on exit from the DataStage Director. 

If Main window size and position is selected, the DataStage 
Director is restarted at the same screen coordinates as when it 
exited. 

If Filter settings is selected, the current filter settings are saved 
and used when the DataStage Director is started. 

Both check boxes are selected by default.

Limits Page
The Limits page sets the maximum number of rows to process in a 

job run, and the maximum number of warning messages to allow 

before a job aborts. The limits apply to all server jobs in the current 

session. You can override the settings for an individual job when it is 

validated, run, or scheduled.
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Setting the Maximum Number of Rows

The option buttons set the maximum number of rows to be processed 

by the job. Click No limit to process all rows or Stop stages after n 
rows to specify a number of rows. 

Enter a value 1 thru 99999 or click the arrow buttons to increase or 

decrease the value. The default value is 1000. 

Setting the Maximum Number of Warnings 

The option buttons set the maximum number of warning messages 

allowed before a job is aborted. Select No limit to log all error 

messages or Abort job after to specify a number of warning 

messages. Enter a value 1 thru 99999 or click the arrow buttons to 

increase or decrease the value. The default value is 50. 

View Page 
The options on the View page determine what is displayed in the 

DataStage Director window.

The check boxes in the Show area are selected by default:

Specify the view to display when the Director is started, by clicking the 

appropriate option button:

Status of jobs (the default setting)

Toolbar Displays the toolbar.

Status bar Displays the status bar. 

Date and time Displays the date and time (of the server) on the status bar.

Icons Displays the icons in the views.
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Schedule

Log for last job

Priority Page 
The Priority page is included for sites where the DataStage client and 

server components are installed on the same computer (this currently 

excludes systems running parallel jobs). When jobs are running, the 

performance of the DataStage Director may be noticeably slower. You 

can improve the performance by changing the priority of the 

DataStage Director process. 

Setting the Process Priority 

The option buttons in the Set process priority area allow you to 

change the priority of the DataStage Director process. 

Click High always to increase the priority of the DataStage 
Director, regardless of where the client and server components 
are installed. Note that if you choose this option and the client and 
server components are installed on different computers, you may 
not see an improvement in the performance of the DataStage 
Director. 

Click High if project on local system to increase the priority of 
the DataStage Director process if the client and server 
components reside on the same machine. This is the default 
setting. 

Click Normal always if you do not want to change the priority 
setting for the DataStage Director process. 

Displaying the Current State 

The Current state area displays the current priority setting.
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Note If you choose a high priority setting, it may take longer for a 

job to run. This is because processor cycles are directed 

toward monitoring jobs rather than running them. 

Click OK to save the settings. 

Choosing an Alternative Project
When you start the DataStage Director, the project chosen in the 

Attach to Project dialog box is opened. You can view the jobs in 

another DataStage project without exiting the DataStage Director. 

Viewing Jobs in Another Project
To view the jobs in another project:

1 Do one of the following to display the Open Project dialog box:

– Choose Project ➤ Open… .

– Click the Open Project button on the toolbar.

2 Choose the project you want to open from the Projects list box. 
This list box contains all the DataStage projects on the server 
specified in the Host system field, which is the server you initially 
attached to.

3 Click OK to open the chosen project. The updated DataStage 
Director window displays the jobs in the new project.

Viewing Jobs on a Different Server
To open a project on a different DataStage server:

1 Click New host… . The Attach to Project dialog box appears. 

2 Enter the name of the DataStage server and your logon details 
before choosing the project from the Project drop-down list. 
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3 Click OK to open the chosen project. The updated DataStage 
Director window displays the jobs in the new project.

Note If you have Monitor windows open when you choose an 

alternative project, you are prompted to confirm that you 

want to change projects. If you click Yes, the Monitor 

windows are closed before the new project is opened. See 

Chapter 5, "Monitoring Jobs," for more details.

Exiting the DataStage Director
To exit the Director, choose Project ➤ Exit. Any open windows (for 

example, Monitor windows) are automatically closed on exit.
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3
Running DataStage Jobs

This chapter describes how to run DataStage jobs, including the 

following topics:

Setting job options

Validating jobs

Starting, stopping, and resetting a job run

Deleting jobs from a project

Cleaning up the resources of jobs that have hung or aborted

Creating multiple job invocations

Setting tracing for parallel jobs

Generating operational meta data

Disabling message handlers for parallel jobs

These tasks are performed from the Job Status view in the DataStage 

Director window. To switch to this view, choose View ➤ Status, or 

click the Status button on the toolbar. 

Setting Job Options
Each time you validate, run, or schedule a job you can:

Change the job parameters associated with the job, as 
appropriate, and set values for environment variables that have 
been defined as job parameters. (You can also set up default 
values for job parameters).
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Override any default limits for row processing (server jobs and job 
sequences only) and warning messages that are set for the job 
run.

Assign Invocation IDs to create multiple job invocations. You can 
create as many invocations as you want. For more information on 
creating Multiple Job Invocations see "Multiple Job Invocations" 
on page 3-17. 

Set tracing options for server jobs and job sequences. For more 
information, see "Setting Tracing Options" on page 3-20.

Override the project default setting for generating operational 
meta data.

You do this from the Job Run Options dialog box which appears 

automatically when you run, validate, or schedule a job. 

Some parameters have default values assigned to them. You can use 

the default or enter another value. You can reinstate the default values 

by clicking Set to Default or All to Default. In the example screen, 

the default values are encrypted strings which are shown as asterisks. 

You can also set your own defaults for job parameters from the 

Director.

Some job parameters hold variable information such as dates or file 

names that you need to enter for each job run. You must enter 

appropriate values in all the fields before you can continue.

If the job’s designer included help text for the job parameters, you can 

get help by selecting the parameter and clicking Property Help.

You can also use this dialog box to set values for environment 

variables that affect parallel job runs. When you design the job, you 

can add environment variables to the list of job parameters, this 

dialog box will then ask you to supply values for those variables for 

this run. Environment variables are identified by a $ sign. When 

setting a value for an environment variable, you can specify the 

special value $ENV or $PROJDEF, which instructs DataStage to use the 
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current setting for the environment variable, or $UNSET which 

instructs DataStage to unset the environment variable (see "The 

DataStage Environment on UNIX" in DataStage Administrator Guide 

for more details about $ENV, $PROJDEF, and $UNSET). 

Note The dialog box displays a Parameters page only if the job 

has parameters.

Validating a Job
You can check that a job or job invocation will run successfully by 

validating it. Jobs should be validated before running them for the 

first time, or after making any significant changes to job parameters.

When a server job is validated, the following checks are made without 

actually extracting, converting, or writing data:

Connections are made to the data sources or data warehouse.

SQL SELECT statements are prepared.

Files are opened. Intermediate files in Hashed File, UniVerse, or 
ODBC stages that use the local data source are created, if they do 
not already exist. 

When a parallel job is validated, the job is run in ‘check only’ mode so 

data is not affected.

To validate a job:

1 Select the job or job invocation you want to validate in the Job 
Status view.

2 Choose Job ➤ Validate… . The Job Run Options dialog box 
appears. See "Setting Job Options" on page 3-1.

3 Fill in the job parameters as required.

4 Click Validate. Click OK to acknowledge the message. The job is 
validated and the job’s status is updated to Running.

Note It may take some time for the job status to be updated, 

depending on the load on the server and the refresh rate for 

the client.

Once validation is complete, the updated job’s status displays one of 

these status messages:

Validated OK. You can now schedule or run the job.

Failed validation. You need to view the job log file for details of 
where the validation failed. For more details, see Chapter 6, "The 
Job Log File." 
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If you want to monitor the validation in progress, you can use a 

Monitor window. For more information, see Chapter 5, "Monitoring 

Jobs."

Running a Job
You can run a job in two ways:

Immediately. 

By scheduling it to run at a later time or date. See "Job 
Scheduling" on page 3-7 for how to do this. 

If you run a job immediately, you must ensure that the data sources 

and data warehouse are accessible, and that other users on your 

system will not be affected by the job run. To run a job immediately:

1 Select the job or job invocation in the Job Status view.

2 Do one of the following:

– Choose Job ➤ Run Now… .

– Click the Run button on the toolbar.

The Job Run Options dialog box appears. See "Setting Job 

Options" on page 3-1.

3 Fill in the job parameters and check warning and row limits for the 
job, as appropriate.

4 Optionally, click Validate to validate the job.

5 Click Run. The job is scheduled to run with the current date and 
time and the job’s status is updated to Running.

Note It may take some time for the job status to be updated, 

depending on the load on the server and the refresh rate for 

the client.

All types of job in your project are displayed in the Director job 

category pane. This can include RTI jobs, which are distinguished by 

having a separate icon and being grayed out:
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If you attempt to run an RTI enabled job from within the Director, you 

will be warned with the following message:

job is RTI enabled. You should use RTI console to start this job if you 
want RTI to process service requests.

Are you sure you want to continue?

Stopping a Job
To stop a job that is currently running:

1 Select it in the Job Status view.

2 Do one of the following:

– Choose Job ➤ Stop.

– Click the Stop button on the toolbar.

The job or invocation is stopped, regardless of the stage currently 

being processed, and the job’s status is updated to Stopped.

Note It may take some time for the job status to be updated, 

depending on the load on the server and the refresh rate for 

the client.

Resetting a Job
If a job has stopped or aborted, it is difficult to determine whether all 

the required data was written to the target data tables. When a job has 

a status of Stopped or Aborted, you must reset it before running the 

job again.

By resetting a job, you set it back to a runnable state and, optionally, 

return your target files to the state they were in before the job was 

run. 

Note You can only reinstate sequential files and hashed files to a 

prerun state if the backup option has been chosen on the 

corresponding stage in the job design.

If you want to undo the updates performed during a successful job, 

you can also use the Reset command for jobs with a status of 

Finished. The Reset command is not available for jobs with a status 

of Not compiled or Running.

To reset a job or job invocation:
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1 Select the job or invocation you want to reset in the Job Status 
view.

2 Choose Job ➤ Reset or click the Reset button on the toolbar. A 
message box appears.

3 Click Yes to reset the tables. All the files in the job are reinstated 
to the state they were in before the job was run. The job’s status is 
updated to Has been reset. 

Note It may take some time for the job status to be updated, 

depending on the load on the server and the refresh rate for 

the client.

Restarting Job Sequences
If a sequence is restartable (i.e., is recording checkpoint information) 

and has one of its jobs fail during a run, then the following status 

appears in the DataStage Director:

Aborted/restartable

In this case you can take one of the following actions:

Run Job. The sequence is re-executed, using the checkpoint 
information to ensure that only the required components are re-
executed.

Reset Job. All the checkpoint information is cleared, ensuring 
that the whole job sequence will be run when you next specify run 
job.

Note If, during sequence execution, the flow diverts to an error 

handling stage, DataStage does not checkpoint anything 

more. This is to ensure that stages in the error handling 

path will not be skipped if the job is restarted and another 

error is encountered.

Setting Default Job Parameters
You can set default values for any parameters a job has. These will 

override an defaults set in the job design (although note that, if you 

recompile the job, the defaults will be reset to the design ones, 

similarly if you upgrade DataStage).

To set default parameters:
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1 Select the job in the display area.

2 Choose Job ➤ Set Defaults…. The Set Job Parameter 
Defaults dialog box appears.

3 If defaults have been set in the Designer for this job, they will be 
displayed. Edit them to override them.

Job Scheduling
You can schedule a job to run in a number of ways:

Once today at a specified time

Once tomorrow at a specified time

On a specific day and at a particular time

Daily at a particular time

On the next occurrence of a particular date and time

Each job can be scheduled to run on any number of occasions, using 

different job parameters if necessary. For example, you can schedule a 

job to run at different times on different days.The scheduled jobs are 

displayed in the Job Schedule view. For example, you can schedule it 

to run at different times on different days.

Note Windows restricts job scheduling to administrators, 

therefore you need to be logged on as a Windows 

administrator in order to use the DataStage scheduling 

features. Microsoft have published a workaround to this 

restriction – visit http://support.microsoft.com/directory/ and 

look up article Q124859 for details.

Note In order to schedule jobs on AIX, the permission of /usr/

spool/cron/atjobs must be changed from 770 to 775 

(rwxrwxr-x). 
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If you experience problems scheduling jobs, see "Windows 

Scheduling Problems" or "UNIX Scheduling Problems" in DataStage 

Administrator Guide.

Job Schedule View
The Job Schedule view displays details of all scheduled and 

unscheduled jobs and batches in the currently selected job category. If 

the job category pane is hidden, the Job Schedule view displays 

details of all scheduled and unscheduled jobs and batches in the 

project, regardless of their job category. 

To display the job schedule, choose View ➤ Schedule or click the 

Schedule button on the toolbar. 

You can filter the view to display specific types of job, based on their 

name or status (see "Filtering the Job Status or Job Schedule View" 

on page -11). The icon on the left of the Job name column indicates 

that a job is scheduled. 

The To be run column shows when the job is scheduled to run, as 

shown in the following table:

To be run… Means this…

Every n n is a number representing the date. For example, Every 12&27 
means the job is scheduled to run on the 12th and 27th day of each 
month. 
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The At time column lists the time at which the job will run. This is 

displayed in the system’s current time format: 12-hour or 24-hour 

clock.

The Parameters/Description column lists the parameters required 

to run the job. Each job has built-in job parameters which must be 

entered when you schedule or run a job. The entered values are 

displayed in this column in the following format:

parameter1 name = value, parameter2 name = value, … 

A brief description appears here if there is a short description defined 

and there are no job parameters.

Viewing Details of a Job Schedule
To view more details about a scheduled job or batch, select it in the 

display area and do one of the following:

Every x x represents the day of the week:

M = Monday

T = Tuesday

W = Wednesday

Th = Thursday

F = Friday

S = Saturday

Su = Sunday

For example, Every Th&F means the job is scheduled to run every 
Thursday and Friday. 

Every n&x n is a date and x is a day of the week (as above). For example, 
Every 10&Su means the job is scheduled to run on every 10th day 
of the month and every Sunday. 

Today The job is run today at the specified time.

Tomorrow The job will run tomorrow at the specified time.

Next n n is a date (as above). For example, Next 28 means the job is run 
on the next 28th of the month.

Next x x is a day of the week. For example, Next W means the job is run 
the next Wednesday in the month. 

Next n&x n is a number and x is a day of the week. For example, Next 
5&12&T means the job is scheduled to run on the next 5th and 
12th day of the month, and the next Tuesday.

To be run… Means this…
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Choose View ➤ Detail.

Choose Detail from the shortcut menu. 

Double-click the job or batch in the display. 

If you choose a batch, it has the same effect as choosing Tools ➤ 

Batch, as described in "Creating a Job Batch" on page 4-1.

If you choose a job, the Job Schedule Detail dialog box appears:

This dialog box contains a summary of the job details and all the 

settings used to schedule the job.

Note The parameter name displayed here is the name used 

internally by the job, not the descriptive parameter name 

you see when you enter job parameter values. 

Use Copy to copy the schedule details and job parameters to the 

Clipboard for use elsewhere.

This field… Contains this information…

Project The name of the project and the DataStage server.

Schedule # The schedule number the job has been assigned.

Occurrences The number of times the job will be run using this schedule. A 
value of Repeats means that the job is continuously 
rescheduled. 

Job name The name of the job.

Run time The time the job is set to run, in 24-hour format.

Run date The date the job is set to run. 

Job parameters The job parameters. Each entry in this field is in the format 
parameter name=value.
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Click Next or Previous to display schedule details for the next or 

previous job in the list. These buttons are only active if the next or 

previous job is scheduled to run.

Click Close to close the window. 

Scheduling a Job
To schedule a job:

1 Select the job or job invocation you want to schedule in the Job 
Status or Job Schedule view.

Note You cannot schedule a job with a status of Not compiled 

or an RTI-enabled job.

2 Do one of the following to display the Add to schedule dialog 
box:

– Choose Job ➤ Add to Schedule… .

– Choose Add To Schedule… from the appropriate shortcut 
menu.

– Click the Schedule button on the toolbar.

3 Choose when to run the job by clicking the appropriate option 
button:

Today runs the job today at the specified time (in the future).

Tomorrow runs the job tomorrow at the specified time.

Every runs the job on the chosen day or date at the specified time 

in this month and repeats the run at the same date and time in the 

following months.

Next runs the job on the next occurrence of the day or date at the 

specified time.

Daily runs the job every day at the specified time.
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4 If you selected Every or Next in step 3, choose the day to run the 
job by doing one of the following:

– Choose an appropriate day or days from the Day list. 

– Choose a date from the calendar. 

Note If you choose an invalid date, for example, 31 

September, the behavior of the scheduler depends upon 

the server operating system, and you may not receive a 

warning of the invalid date. Refer to your server 

documentation for further information.

5 Choose the time to run the job. There are two time formats:

– 12-hour clock. Click either AM or PM.

– 24-hour clock. Click 24H Clock.

Click the arrow buttons to increase or decrease the hours and 

minutes, or enter the values directly. 

6 Click OK. The Add to schedule dialog box closes and the Job 
Run Options dialog box appears.

7 Fill in the job parameter fields and check warning and row limits, 
as appropriate. 

8 Click Schedule. The job is scheduled to run and is added to the 
Job Schedule view.

Unscheduling a Job
If you want to prevent a job from running at the scheduled time, you 

must unschedule it. To unschedule a job:

1 Select the job you want to unschedule in the Job Schedule view.

2 Do one of the following:

– Choose Job ➤ Unschedule. 

– Choose Unschedule from the Job shortcut menu.

If the job is not scheduled to run at another time, the job status is 

updated to Not scheduled in the To be run column, and is not run 

again until you add it to the schedule. 

Rescheduling a Job
If you have a job scheduled to run, but you want to change the 

frequency, day, or time it is run, you can reschedule it. To reschedule a 

job:
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1 Select the job you want to reschedule in the Job Schedule view.

2 Do one of the following to display the Add to schedule dialog 
box:

– Choose Job ➤ Reschedule… . 

– Choose Reschedule… from the Job shortcut menu.

– Click the Reschedule button on the toolbar.

The current settings for the job are shown in the dialog box.

3 Edit the frequency, day, or time you want the job to run.

4 Click OK. The Add to schedule dialog box closes and the Job 
Run Options dialog box appears. 

5 Fill in the job parameters and check warning and row limits as 
appropriate.

6 Click Reschedule. The job is rescheduled and the To be run 
column in the Job Schedule view is updated. 

Deleting a Job
You can remove unwanted or old versions of jobs from your project as 

follows: 

1 Select the job or job invocation in the Job Status view. You can 
make multiple selections.

2 Choose Job ➤ Delete. A message confirms that you want to 
delete the chosen job, or jobs.

3 Click Yes to delete the jobs. A message confirms they have been 
deleted.

4 Click OK. The jobs and all the associated components used at run 
time are deleted, including the files and records used by the Job 
Log view and the Monitor window. 

5 If you delete a job that is part of a batch, edit the batch to remove 
the deleted job to prevent the batch from failing. See Chapter 4, 
"Job Batches."

If you delete the last server job from a job category, that category is 

removed from the job category tree in the Director window.
Director Guide 3-13



Job Administration Running DataStage Jobs
Job Administration
From the DataStage Administration client, the administrator can 

enable job administration commands that let you clean up the 

resources of a job that has hung or aborted. These commands help 

you return the job to a state in which you can rerun it after the cause 

of the problem has been fixed. You should use them with care, and 

only after you have tried to reset the job and you are sure it has hung 

or aborted.

There are two job administration commands:

Cleanup Resources

Clear Status File

Cleaning Up Job Resources
This facility only applies to server jobs. The Cleanup Resources 

command lets you:

View and end job processes

View and release the associated locks 

To run this command, do one of the following:

Choose Job ➤ Cleanup Resources from the menu bar. 

Choose Cleanup Resources from the Monitor window shortcut 
menu.

The Job Resources dialog box appears, from which you can view 

and clean up the resources of the selected job:
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In the Processes area:

In the Locks area:

This column… Displays this information…

PID # The process identification number.

Context The process context. In a job with more than one active stage, 
a PID may be reused during a job run. In that case the context 
field may have entries for more than one active stage. The 
context will always be listed as Unavailable if the Show All 
option button is selected.

User Name The identity of the user whose job started the process.

Last Command 
Processed 

The command executed most recently by the process.

This column… Displays this information…

PID/User # The identification number of the process associated with the 
lock.

Lock Type The type of lock: File, Record, or Group.

Item Id The identity of the item (record) locked by the process. For a 
Group lock, this column is left blank.
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Viewing Processes and Locks

The default is for the Job Resources dialog box to display all the 

processes and locks associated with the job currently selected in the 

DataStage Director. You can, however, filter the display by using the 

option buttons in the Processes and Locks areas of the Job 
Resources dialog box.

In the Processes area:

Show All displays all current DataStage processes.

Show by job (the default) displays all processes for the selected 
job.

In the Locks area:

Show All displays all the current locks.

Show by job (the default) displays all locks for the selected job.

Show by process displays all the locks associated with the 
process that you have selected in the Processes area in the Job 
Resources dialog box.

Ending Job Processes

To end job processes:

1 From the Job Resources dialog box, choose the range of 
processes to list by using the Show All or Show by job option 
buttons in the Processes area.

2 To end all the processes associated with a job, click Logout All. 
(This button is disabled if you have clicked the Show All option 
button.)

To end a particular process, select the process in the Processes 

list box, then click Logout.

3 Wait for the processes to end (log out) and the display to update.

You can refresh the display manually at any time by clicking Refresh.

If this procedure fails to end a process that you believe is causing a 

job to hang, try the following steps:

1 Log out of all DataStage clients.

2 Try to end the process using the Windows Task Manager or kill the 
process in UNIX.

3 Stop and restart the DataStage Server Engine.

4 Reset the job from the DataStage Director (see "Resetting a Job" 
on page -5).
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If there is a problem with a job, you can also release locks (see the 

next section), or clear the job status file (see "Clearing a Job Status 

File" on page 3-17). 

Releasing Locks

To release locks:

1 From the Job Resources dialog box, choose the range of locks to 
list by doing either of the following:

– Click the Show by job option button in the Locks area. 

– Select a process in the Processes area, then click the Show 
by process option button.

Note You cannot release locks if you have clicked the Show 
All option button in the Locks area.

2 Click Release All. Each of the displayed locks is unlocked and the 
display updates automatically. (You cannot select or release 
individual locks.)

You can refresh the display manually at any time by clicking Refresh.

Clearing a Job Status File
When you clear a job’s status file you reset the status records 

associated with all stages in that job. You should therefore use this 

option with great care, and only when you believe a job has hung or 

aborted. In particular, before you clear a status file you should:

1 Try to reset the job (see "Resetting a Job" on page -5). 

2 Ensure that all the job’s processes have ended (see "Ending Job 
Processes" on page 3-16). 

To clear the job status file, choose Job ➤ Clear Status File from the 

menu bar. The job status changes to Compiled and no evidence will 

remain that the job has ever run.

If there is a problem with a job, you can also release the locks (see 

"Releasing Locks" on page 3-17).

Multiple Job Invocations
You can create multiple invocations of a DataStage server or parallel 

job, with each invocation starting with different parameters to process 

different data sets. A job invocation can be invoked regardless of the 

state of other invocations which are processing different data sets.
Director Guide 3-17



Multiple Job Invocations Running DataStage Jobs
If you run a job in the Director without giving an invocation Id then 

you can't create any new invocations of that job until the job has 

finished. If you want to run several invocations of the same job at the 

same time, you must give an invocation Id for the first invocation.

The job designer should ensure that the job is suitable to have 

multiple invocations run. For example, an unsuitable job may have 

different invocations running concurrently and writing to the same 

table. An unsuitable job may also adversely affect job performance.

Parallel job invocations resulting from a decision to invoke multiple 

invocations of a job should not be confused with the several instances 

of the same job that you get when running a partitioned job across 

several processors. In the latter case the partitioning and collecting 

built-in to the job will handle the situation where several processes 

want to read or write to the same data source.

Creating Multiple Job Invocations

1 You enable multiple job invocations from the DataStage Designer. 
You must select the Allow Multiple Instance option on the Job 
Properties page. See the "Job Properties" in DataStage Designer 
Guide for more details on editing job properties.

2 Compile the job as normal. See "Compiling Server Jobs and 
Parallel Jobs" in DataStage Designer Guide for more details on 
compiling jobs.

Note When you recompile an job, the invocations are 

canceled, and new invocations will have to be 

recreated. This is to ensure that job integrity is 

maintained after job design changes.

3 From the Job Status view select the job, and choose Job ‰ 
Validate. The Job Run Options dialog box appears:
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4 Enter an Invocation Id in the text field. This will be suffixed to the 
job name to create the invocation. For example if the job name is 
‘Exercise 5’ and you enter an Invocation Id of ‘Test1’, then job will 
appear as ‘Execrcise5.Test1’.

5 Click Validate. The Job Status view now shows the new job 
invocation:

Running a Job Invocation

Running an invocation is done in the same way as you would other 

jobs.

1 From the Job Status view select the invocation from the list and 
choose Job ‰ Run now. The Job Run Option dialog appears:

2 Fill in any Parameters, Rows and Warning Limits as required. Click 
Run.

Note Another way to run an invocation is to choose the job from 

the list, enter the Invocation Id in the text field and then click 

Run.

Viewing the Job Log for an Invocation

Viewing the job log for job invocations is exactly the same as for 

viewing other job log.
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Setting Tracing Options
Server Jobs The Tracing page is included in the Job Run Options dialog box to 

help Ascential Software analysts during troubleshooting. You can 

generate tracing information and performance statistics for server 

jobs.

The options on this page determine the amount of diagnostic 

information generated the next time a job is run. Diagnostic 

information is generated only for the active stages in a chosen job. To 

specify the job, highlight it in the Job Status or Job Schedule view 

before choosing Tools ➤ Options… .

The Stage names list box contains the names of the active stages in 

the job in the format jobname.stagename. To set a trace level, 

highlight the stages in the Stage names list box, then select any of 

the following check boxes:

Report row data. Records an entry for every data row read on 
input and written on output. This check box is cleared by default.

Property values. Records an entry for every input and output 
opened and closed. This check box is cleared by default.

Subroutine calls. Records an entry for every BASIC subroutine 
used. This check box is cleared by default.

Performance statistics. When performance tracing is turned on 
a special log entry is generated immediately after the stage 
completion message. This contains performance statistics about 
the selected stages statistics in a tabular form. (For more 
information see "Optimizing Performance in Server Jobs" in 
Server Job Developer’s Guide)

When the job runs, a file is created for each active stage in the job. The 

files are named using the format jobname.stagename.trace and are 

stored in the &PH& subdirectory of your DataStage server installation 
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directory. If you need to view the content of these files, contact your 

local Ascential Customer Support center for assistance.

Generating Operational Meta Data
If you have installed the Process MetaBroker, you can capture process 

meta data from DataStage jobs by selecting the Generate 
operational meta data check box on the General tab of the Job 
Run Options dialog box. MetaStage can then collect meta data that 

describes the job run. The setting on this page overrides the default 

setting for the project made in the DataStage Administrator client. 

To facilitate the collection of process meta data, you should create 

locator tables in any source or target databases that your DataStage 

jobs access. DataStage uses this information during jobs runs to 

create a fully qualified locator string identifying table definitions for 

MetaStage’s benefit. See "Capturing Process Meta Data" in DataStage 

Administrator Guide for instructions on how to do this.

Disabling Message Handlers 
Parallel jobs When you run a parallel job you can disable any message handler that 

have been defined for that job.

For parallel jobs, you can define message handlers, which specify that 

particular types of informational or warning messages are suppressed 

from the log. Message handlers can be assigned to jobs at the project 

level (from the DataStage Administrator), the Job Design level (from 

the DataStage Designer), or for individual job runs (from the Director). 

You can define a handler from the Director, or from the DataStage 

Manager. For more details see "Message Handlers" on page 6-9.
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Message handlers are disabled on the General page of the Job Run 
Options dialog box (shown on page 3-21). To disable message 

handling:

Select Disable project-level message handling to disable the 
handler that has been defined in the DataStage Administrator to 
apply to all jobs in the project.

Select Disable compiled-in job-level message handling to 
disable a local handler that has been compiled into this particular 
job.

The message handlers are only disabled for this particular job run.
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Job Batches

This chapter describes how to create and run DataStage job batches, 

including the following topics:

What is a job batch

Creating and running job batches

Scheduling, unscheduling and rescheduling job batches

Deleting batches from a project

What Is a Job Batch?
A job batch is a group of jobs or separate invocations of the same job 

(with different job parameters) that you want to run sequentially. 

DataStage treats a batch as though it were a single job. If any job fails 

to complete successfully, the batch run stops. You can follow the 

progress of jobs within a batch by examining the log files of each job 

or of the batch itself. These contain messages about the progress of 

the batch, as well as the job. You can create, schedule, edit, or delete 

job batches.

Creating a Job Batch
To create a job batch:
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1 Choose Tools ➤ Batch ➤ New… . The Create New Batch 
dialog box appears:

2 Enter a name for the new batch in the Batch name field. You can 
also select it from the list of existing batches and categories.

3 In the Category field, enter the name of the job category in which 
the new batch will be created. You can also select it from the list of 
existing batches and categories. If you leave the Category field 
blank, the new batch is located below the Jobs node in the job 
category tree.

4 Click OK. The Job Properties dialog box appears:
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5 Select the jobs to add to the batch from the Add Job list on the 
Job control page (note that you cannot add an RTI-enabled job to 
a job batch). This list displays all the server and parallel jobs in the 
project. You are prompted to enter parameter values, and row and 
warning limits for each job in the batch. As each job is added to 
the batch, the control information is added to the Job control 
page.

6 Click the General tab. The General page appears at the front of 
the Job Properties dialog box. Optionally, enter a brief 
description of the batch in the Short job description field. This 
description appears in the Parameters/Description column in 
the Job Schedule view.

7 Optionally, enter a more detailed description of the batch in the 
Full job description field. 

8 Click the Parameters tab. The Parameters page appears at the 
front of the Job Properties dialog box.

9 Define any parameters that you want to specify for the batch. For 
example, a user name and password to prompt for when the batch 
is run. 

10 When you have defined the batch, click OK. The batch is compiled 
and appears in the Job Status view.

Note The Dependencies page allows you to specify the 

dependencies of the batch job. You only need to do this if 

you intend to package the batch job for deployment on 

another system using the DataStage Manager. Information 

on dependencies and packaging jobs is in"Specifying Job 

Dependencies" in DataStage Designer Guide, and "Using 

the Packager Wizard" in DataStage Manager Guide.

Running a Job Batch
You can run a job batch in the same way as a standard job: 

Immediately. 

By scheduling it to run at a later time or date. See "Scheduling a 
Job Batch" on page 4-4 for how to do this. 

If you run a batch immediately, you must ensure that the data sources 

and data warehouse are accessible, and that other users on your 

system will not be affected by the job run.

To run a batch immediately:

1 Select the batch in the Job Status view.

2 Do one of the following:
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– Choose Job ➤ Run Now… .

– Click the Run button on the toolbar.

The Job Run Options dialog box appears. See "Setting Job 

Options" on page 3-1.

3 Fill in the job parameters and check warning and row limits for the 
batch, as appropriate.

4 Optionally, click Validate to validate the job.

5 Click Run. The batch is started and its status is updated to 
Running.

Note It may take some time for the job status to be updated, 

depending on the load on the server and the refresh rate for 

the client.

Scheduling a Job Batch
To schedule a batch:

1 Display the Job Schedule view. Job batches are displayed in the 
Job Schedule view in the format Batch::batchname. batchname is 
the name entered when the batch was created.

2 Select the batch in the list and do one of the following to display 
the Add to schedule dialog box:

– Choose Job ➤ Add to Schedule… .

– Choose Add To Schedule… from the Job shortcut menu.

– Click the Schedule button on the toolbar.

3 Choose when to run the batch by clicking the appropriate option 
button:

Today runs the batch today at the specified time (in the future).
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Tomorrow runs the batch tomorrow at the specified time.

Every runs the batch on the chosen day or date at the specified 

time in this month and repeats the run at the same date and time 

in the following months.

Next runs the batch on the next occurrence of the day or date at 

the specified time.

Daily runs the batch every day at the specified time.

4 If you selected Every or Next in step 3, choose the day to run the 
batch from the Day list or a date from the calendar. 

Note If you choose an invalid date, for example, 31 

September, the behavior of the scheduler depends upon 

the server operating system, and you may not receive a 

warning of the invalid date. Refer to your server 

documentation for further information.

5 In the Time area, select one option from AM, PM, or 24H Clock. 
Then click the arrow buttons to increase or decrease the hours and 
minutes, or enter the values directly. 

6 Click OK. The Add to schedule dialog box closes and the Job 
Run Options dialog box appears.

7 Click Schedule. The batch is scheduled to run and is added to the 
Job Schedule view. The job parameters entered when the batch 
was created are used when the batch is run.

Unscheduling a Job Batch
If you want to prevent a batch from running at the scheduled time, you 

must unschedule it. To unschedule a batch, select the batch in the Job 

Schedule view and do one of the following:

Choose Job ➤ Unschedule. 

Choose Unschedule from the Job shortcut menu.

The batch status is updated to Not scheduled in the To be run 

column and is not run again until you schedule it again. 

Rescheduling a Job Batch
If you have a batch scheduled to run, but you want to change the 

frequency, day, or time it is run, you can reschedule it. To reschedule a 

batch:
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1 Select the batch in the Job Schedule view and do one of the 
following:

– Choose Job ➤ Reschedule… . 

– Choose Reschedule… from the Job shortcut menu.

– Click the Reschedule button on the toolbar.

The Add to schedule dialog box appears with the current 

settings for the batch.

2 Edit the frequency, day, or time you want the batch to run.

3 Click OK. The Add to schedule dialog box closes, the batch is 
rescheduled, and the To be run column in the Job Schedule view 
is updated. 

Job Schedule Errors
If you get an error when you try to schedule jobs, ask your system 

administrator to check that:

The Windows Schedule service is running on the server (see the 
"Starting the Schedule Service" in DataStage Administrator 
Guide).

You belong to a Windows group that has permission to use the 
Schedule service. 

Editing a Job Batch
To add or remove jobs from a job batch or change any job parameters, 

you must edit the job batch. 

Note Do not edit a job batch while it is running.

To edit a job batch:

1 Select the batch and choose Tools ➤ Batch ➤ Properties. The 
Job Properties dialog box appears.

2 Add further jobs by selecting them in the Add Job list, or remove 
jobs from the batch by selecting them in the Job control page 
and using the Cut button or the Delete key.

3 Click the General tab and edit the batch description, if required. 

4 Click the Parameters page and edit the batch parameters, if 
required. 

5 Click OK to save the edits. 
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Copying a Job Batch
To copy a job batch:

1 In the Job Status view, select the batch and choose Tools ➤ 
Batch ➤ Save As… . The Save Batch As dialog box appears.

2 Enter the name for the new copy of the batch.

3 Enter the name of the job category in which the copy of the batch 
will be held. If you leave the Category field blank, the new batch 
is located below the Jobs node in the job category tree.

4 Click OK to copy the batch.

Deleting a Job Batch
If you do not need a job batch, you can delete it. To delete job batches:

1 Select the batch, or batches, in the Job Status view. 

2 Choose Tools ➤ Batch ➤ Delete. A message appears asking you 
to confirm the deletion.

3 Click Yes to delete the batch or batches.
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Monitoring Jobs

This chapter describes how to monitor running jobs using the 

Monitor command. Processing details that occur at each active stage 

of the job are displayed in a Monitor window. These details include:

The name of the stages performing the processing

The status of each stage

The number of rows processed

The time taken to complete each stage

For parallel jobs, where the job is partitioned and different instances 

are running on different processors, the monitor can provide 

information for each instance if you request this option.

The Monitor Window
To display a Monitor window, select a job in the Job Status view and 

do one of the following:

Choose Tools ➤ New Monitor.

Choose Monitor from the shortcut menu.

(You can also start the monitor from the Tools menu of the DataStage 

Designer).

The monitor opens, displaying a tree structure containing stages in a 

job and associated links. For server jobs active stages are shown 

(active stages are those that perform processing rather than ones 
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reading or writing a data source). For parallel jobs, all stages are 

shown. 

The window displays the following information when you select a 

stage in the tree:

If you are monitoring a parallel job, and have not chosen to view 

instance information (see page 5-3), the monitor displays information 

for Parallel jobs as follows:

This 
column…

Contains this information…

Status The status of each stage. The possible states are:

State Meaning

Aborted The processing terminated abnormally at this 
stage. 

Finished All data has been processed by the stage.

Ready The stage is ready to process the data.

Running Data is being processed by the stage.

Starting The processing is starting.

Stopped The processing was stopped manually at this 
stage.

Waiting The stage is waiting to start processing.

Num Rows The number of rows of data processed so far by each stage on its 
primary input. 

Started at The time the processing started on the server.

Elapsed time The elapsed time since processing started.

Rows/sec The number of rows processed per second.

%CP The percentage of CPU the stage is using (you can turn the 
display of this column on and off from the shortcut menu – see 
"Showing CPU Usage" on page 5-5).
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If a stage is running in parallel then x N is appended to the stage 
name, where N gives how many instances are running. 

If a stage is running in parallel then the Num Rows column shows 
the total number of rows processed by all instances. The Rows/sec 
is derived from this value and shows the total throughput of all 
instances.

If a stage is running in parallel then the %CP may be more than 
100 if there are multiple CPUs on the server. For example, on a 
machine with four CPUs, %CP could be as high as 400 where a 
stage is occupying 100% of each of the four processors, on the 
other hand, if the stage is occupying only 25% of each processor 
the %CP would be 100%.

To monitor instances of parallel jobs individually, choose Show 
Instances from the shortcut menu. The monitor will then show each 

instance of a stage as a sub-branch under the ‘parent’ stage, The 

monitor displays the information for all stage instances under the 

‘parent’ stage. Only relevant information is shown for each stage 

instance as follows:

This 
column…

Contains this information…

Status The status of each stage. The possible states are:

State Meaning

Aborted The processing terminated abnormally at this 
stage. 

Finished All data has been processed by the stage.

Ready The stage is ready to process the data.

Running Data is being processed by the stage.

Starting The processing is starting.

Stopped The processing was stopped manually at this 
stage.

Waiting The stage is waiting to start processing.
Director Guide 5-3



The Monitor Window Monitoring Jobs
If you select a link in the tree (either under a stage or a stage instance) 

the following information is shown:

The status bar at the bottom of the window displays the name and 

status of the job, the name of the project and the DataStage server, 

and the current time on the server. 

Monitor Shortcut Menu

The Monitor window shortcut menu allows you to perform the 

following tasks:

Refresh. Refresh the monitor with the most recent information 
(this overrides the interval setting which normally decides how 
often the monitor is refreshed – see page 5-5).

Num Rows The number of rows of data processed so far by each stage on its 
primary input. 

%CP The percentage of CPU the instance is using (you can turn the 
display of this column on and off from the shortcut menu – see 
"Showing CPU Usage" on page 5-5).

This 
column…

Contains this information…

Link Type The type of link as follows:

Type Meaning

<<Pri primary input link

<Ref input link

>Out output link

>Rej output link for rejected rows

Num Rows The number of rows of data processed so far by each stage on its 
primary input. 

Rows/sec The number of rows processed per second.

This 
column…

Contains this information…
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Detail. Select this to display the Stage Status window – see 
page 5-6.

Show Instances. Select this to show details for each instance of 
a parallel job that has been partitioned between processors – see 
page 5-3.

Show %CP. Select this to display the %CP column in the monitor 
– see page 5-5.

Showing CPU Usage

While a stage or stage instance is processing data rows, it can use a 

large portion of the CPU. You can use the Monitor window to check 

what percentage of the computer processor is being used by an active 

stage. 

To show the percentage of CPU usage, choose Show %CP from the 

Monitor shortcut menu. The updated Monitor window includes the 

%CP column. 

The number displayed in the %CP column updates at regular 

intervals. The %CP column is empty if a stage is not processing data 

or has finished. If several running stages share a process, only one of 

the stages displays a value in the %CP column; the other stages 

display the same value in parentheses. 

To hide the %CP column, choose Show %CP from the shortcut menu 

again. 

Setting the Server Update Interval
The Monitor window display is updated with new information from 

the server at regular intervals. You can set how often the updates 

occur by setting a time (in seconds) in the Interval field. Click the 

arrow buttons to increase or decrease the value, or enter the value 

directly. The default setting is 10, the minimum is 5, and the maximum 

is 65.

Note When monitoring parallel jobs, you can specify that the 

monitor window is refreshed every so many entries rather 

than every so many seconds. This is done by setting an 

environment variable in the Administrator client. See 

"Setting Environment Variables" in DataStage Administrator 

Guide for details.
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Switching Between Monitor Windows
You can display a Monitor window before you start the job or while a 

job is running. If you want to monitor more than one job at a time, you 

can display more than one Monitor window. 

If you have several Monitor windows open, they can become hidden 

by other windows on the screen. 

To bring a Monitor window to the front of the screen:

1 Choose Tools ➤ View Monitor.

2 Select the job you want to view from the submenu.

The Stage Status Window
As well as viewing the information in the Monitor window, you can 

obtain more information about each stage from the Stage Status 

window. To display the Stage Status window, select a stage in the 

Monitor window and do one of the following:

Choose Detail from the shortcut menu.

Double-click the stage in the Monitor window.

The fields and parameters displayed in the Stage Status window 

depend on whether you have selected a stage, instance, or a link in 

the monitor window tree. 

The following screen shows the Stage Status window for a selected 

stage:
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If you are looking at an instance of a parallel job stage the stage name 

will be given as Stage.Instance, for example CTransformerSatge1xz.2. 

The fields in the window cannot be edited. 

The following screen shows the Stage Status window if you have 

selected a link:

The same fields described earlier are displayed in this window except:

Stage is replaced by Stage.Link (or Stage.Instance.Link). This 
field contains the name of the stage followed by the name of the 
link.

This field… Displays this information…

Project The name of the project and the DataStage server.

Job name The name of the job.

Stage The name of the stage (or stage and instance)

Status The status of the stage. This is one of the states described on 
page 5-2.

Started at The date and time (on the server) the processing started at this 
stage.

Ended at The date and time (on the server) the processing ended. This 
is set to 00:00:00 or is left blank if processing is still taking 
place.

Row count The number of rows processed.

Control An internal number assigned by DataStage.

Wave # An internal number assigned by DataStage.

User The name or process number of the user who ran the job.

Retrieved The date and time (on the server) the stage retrieved the data 
to process.
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Control is replaced by Link type. This field contains the type of 
link. There are four possible settings:

Primary A primary input link

Reference A reference input link

Output An output link

Reject An output link marked as “Rejected Rows”
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The Job Log File

This chapter describes the job log file and the Job Log view. The job 

log file is updated when you validate, run, or reset a job. You can use 

the log file to troubleshoot jobs that fail during validation, or that are 

aborted when they are run. 

For parallel jobs, you can also define message handlers, which specify 

that particular types of informational or warning messages are 

suppressed from the log. Message handlers can be assigned to jobs at 

the project level (from the DataStage Administrator), the Job Design 

level (from the DataStage Designer), or for individual job runs (from 

the Director). You can define a handler from the Director, or from the 

DataStage Manager. For more details see "Message Handlers" on 

page 6-9.

Job Log View
A job’s log file is displayed in the Job Log view. To display the log file, 

select the job in the Job Status view, then choose View ➤ Log or click 

the View Log toolbar button. The display is updated to list the job log 

file. 
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Each log file contains entries describing events that occurred during 

the last (or previous) runs of the job. The most recent run is shown in 

black, others are shown in blue.

Entries are written to the log when:

A job or batch starts or finishes

A stage starts or finishes

Rejected rows are output (server jobs and some stage types in 
parallel jobs)

Errors are generated

The four columns in the Job Log view are described in the following 

table:

This 
column…

Contains this information…

Occurred The time the event occurred.

On date The date the event occurred.

Type The type of event:

This event… Occurs when…

Info Stages start and finish. No action required. 
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The Event Detail Window
The full message for an event can be viewed in the Event Detail 

window. To display the Event Detail window, select an event in the 

Job Log view and do one of the following:

Choose View ➤ Detail.

Choose Detail from the shortcut menu.

Double-click the event line. 

Press Ctrl-D.

Warning An error occurred. You may need to 
investigate the cause of the warning, as this 
may cause the job to abort. 

Fatal A fatal error occurred. You need to investigate 
the cause of this error.

Control The job starts and finishes.

Reject Rejected rows are output.

Reset A job is reset.

Event A message describing the event. The first line of the message is 
displayed. If a message has an ellipsis (…) at the end, it contains 
more than one line. You can view the full message in the Event 
Detail window.

This 
column…

Contains this information…
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This window contains a summary of the job and event details. The 

fields are described in the following table:

You can use Copy to copy the event details and message or selected 

text to the Clipboard for use elsewhere. 

Click Next or Previous to display details for the next or previous 

event in the list. 

Click Close to close the window.

If you are running a parallel job, and your administrator has enabled 

the Generated OSH Visible option in the DataStage Administrator, 

the Event Detail window contains the OSH that was run for the job. 

This appears after the 'Parallel Job Initiated' message (usually event 

3). This facility is intended for expert users.

This 
field…

Contains this information…

Project The name of the project and the DataStage server.

Event # The ID assigned to the event during the job run.

Event type The type of event. The event types are:

Info

Warning

Fatal

Control

Reject

Reset

For a description of each event type, see page 6-2.

Job name The name of the job.

Timestamp The date and time the event occurred.

User The name of the user who reset, validated, or ran the job.

Message The full event message. The text contains names of stages in the job 
which were processed during this event. If you are viewing an event 
with an event type of Fatal or Warning, this text describes the cause 
of the event. The message also displays data associated with the 
event, unless the DataStage administrator has restricted the 
operator’s view of the log, in which case the data is visible to users 
with Developer rights only (see "Permissions Page" in DataStage 
Administrator Guide).
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Viewing Related Logs
To examine the log entries for a job that was run as part of a batch:

1 Switch to the log entries for the batch itself by selecting a log 
entry.

2 Do one of the following:

– Choose View ➤ Related Log. 

– Choose Related Log from the shortcut menu. 

You see the first log entry for the batch that the job belongs to.

Filtering the Job Log View
By default, the information displayed in the Job Log view includes all 

the events that have occurred for the chosen job, regardless of how 

many times the job has been run. On an established system, the 

display may include more information than you need. 

If you want specific information, for example, a list of all the events 

after a particular date, you can use the Filter facility. 

To start the Filter facility, do one of the following:

Choose View ➤ Filter Entries… from the menu bar.

Choose Filter… from the shortcut menu. 

Press Ctrl-T. 

The Filter dialog box appears:
Director Guide 6-5



Filtering the Job Log View The Job Log File
You can choose to display only those entries between particular dates 

and times. You can also further reduce the entries by displaying only 

those entries with a particular event type. 

To use the Filter facility:

1 Choose where to start the filter by clicking the appropriate option 
button:

– Oldest displays all the entries from the oldest event in the log 
file. 

– Start of last run displays the entries from the start of the last 
run.

– Day and Time displays all the entries from the specified date 
and time. Enter the date and time or click the arrow buttons. 
The format of the date depends on how your Windows system 
is set up, for example, dd\mm\yyyy or mm\dd\yyyy. The time is 
always in 24-hour format.

2 Choose where to end the filter by clicking the appropriate option 
button:

– Newest displays entries up to the most recent date and time.

– Day and Time displays all the entries up to the specified date 
and time. 
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3 Choose what to display from the filtered selection by clicking the 
appropriate option button:

– Select all entries displays all the entries between the chosen 
start and end points. 

– Last displays the last n number of entries, where n is a 
number. The default setting is 100. Click the arrow buttons to 
increase or decrease the value, or enter a value 1 thru 9999.

4 Choose the event types you want to display by selecting the 
appropriate check boxes:

– Information

– Warning

– Fatal

– Reject

– Other. All event types other than those listed above.

5 Click OK to activate the filter. The updated Job Log view displays 
the entries that meet the filter criteria. The status bar indicates that 
the entries have been filtered. 

The Job Log view uses the filter settings until you change them or 

redisplay the whole log file. To display all the entries, choose View ➤ 

Show All. 

Purging Log File Entries
You must purge job log entries routinely so that the log files do not 

become too large. There are three ways to purge log entries:

Automatically for a whole project. This is set up by the DataStage 
administrator. See "Maintaining Job Log Files" in DataStage 
Administrator Guide.

Automatically for each job. You can override any project-wide 
purging policy and set the purging policy for individual jobs. 

Manually for individual jobs.

You purge log entries for a job from the Clear Log dialog box. To 

display this dialog box, select the job in the Job Status view, then 

choose Job ➤ Clear Log… .
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For job shows the name of the job. Oldest entry shows the date and 

time of the oldest entry in the log file. (The format of the date and time 

may look different on your screen depending on your Windows 

settings.)

Purging Log Entries Immediately
Click Immediate purge to select the Immediate area. You set the 

purging criteria by clicking one of the following:

Clear all entries. Deletes all entries in the log file. 

Up to last run. Deletes all entries except the last one.

Before date. Deletes all entries before the specified date. Specify 
the date by clicking the arrow buttons or entering the values 
directly. 

The log file is purged after you click OK.

Purging Log Entries Automatically
Click Auto-purge to select the Auto-purge area. You set the purging 

criteria by clicking one of the following:
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Up to previous (job runs). Purges old log entries, leaving the 
specified number of recent job run entries in the file. 

Older than (days). Purges all log entries older than the specified 
number of days. 

Specify the number of job run entries or days by clicking the arrow 

buttons or entering the value directly.

Click OK to close the dialog box. The log file is purged at the next job 

run, and at subsequent job runs, according to your settings. 

The log files are held in a hash file, and automatically purging the log 

does not actually empty the file. The aim of auto-purge is to purge the 

log regularly so that the hash file does not keep growing, but remains 

at a constant size. To completely empty a log, use the manual purge 

facilities to clear the whole log, then set up auto-purge to keep it at a 

manageable size.

Note that, if you are running multiple invocations of the same job, all 

invocations share the same job log. This means that if you, for 

example, choose to purge entries for all but the last four runs, and the 

job is invoked 6 times, then the entries for only 4 of the invocations 

will be kept. When using invocations to run jobs it may be better to 

auto-purge based on the number of days entries to be kept.

Message Handlers
Parallel Jobs When you run a parallel job, any error messages and warnings are 

written to an error log and can be viewed from the Director. You can 

choose to handle specified errors in a different way by creating one or 

more message handlers. 

A message handler defines rules about how to handle messages 

generated when a parallel job is running. You can, for example, use 

one to specify that certain types of message should not be written to 

the log.

You can edit message handlers in the DataStage Manager or in the 

DataStage Director. The recommended way to create them is by using 

the Add rule to message handler feature in the Director.

You can specify message handler use at different levels:

Project Level. You define a project level message handler in the 
DataStage Administrator, and this applies to all parallel jobs 
within the specified project.
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Job Level. From the Designer and Manager you can specify that 
any existing handler should apply to a specific job. When you 
compile the job, the handler is included in the job executable as a 
local handler (and so can be exported to other systems if 
required).

You can also add rules to handlers  when you run a job from the 

Director (regardless of whether it currently has a local handler 

included). This is useful, for example, where a job is generating a 

message for every row it is processing. You can suppress that 

particular message. 

When the job runs it will look in the local handler (if one exists) for 

each message to see if any rules exist for that message type. If a 

particular message is not handled locally, it will look to the project-

wide handler for rules. If there are none there, it writes the message to 

the job log.

Note that message handlers do not deal with fatal error messages, 

these will always be written to the job log.

Note You cannot add message rules to jobs from an earlier 

release of DataStage without first re-running those jobs.

Adding Rules to Message Handlers
You can add rules to message handlers 'on the fly' from within the 

Director. Using this method, you can add rules to handlers that are 

local to the current job, to the project default handler, or to any 

previously-defined handler.

To add rules in this way, highlight the message you want to add a rule 

about in the job log and choose Add rule to message handler... 
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from the job log shortcut menu or from the Job menu on the menu 

bar. The Add rule to message handler dialog box appears.

To add a rule:

1 Choose an option to specify which handler you want to add the 
new rule to. Choose between the local runtime handler for the 
currently selected job, the project-level message handler, or a 
specific message handler. If you want to edit a specific message 
handler, select the handler from the Message Handler drop-
down list. Choose (New) to create a new message handler.

2 Choose an Action from the drop down list. Choose from:

– Suppress from log. The message is not written to the job's 
log as it runs.

– Promote to Warning. Promote an informational message to a 
warning message.

– Demote to Informational. Demote a warning message to 
become an informational one.

The Message ID, Message type and Example of message 
text fields are all filled in from the log entry you have currently 

selected. You cannot edit these. 

3 Click Add Rule to add the new message rule to the chosen 
handler.
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4 Click Previous or Next to move through the messages in the job 
log and add further rules to the selected handler.

If you click Edit Handler…, the Edit Message Handlers dialog box 

appears, enabling you to manage the message handlers.

Managing Message Handlers
You can view, edit, or delete message handlers  from the Message 

Handler Manager. You can also define new handlers if you are familiar 

with the message IDs (although note that DataStage will not know 

whether such messages are warnings or informational). The preferred 

way of defining new handlers is by using the add rule to message 

handler feature.

To open the Message Handler Manager, choose Tools ➤ Message 
Handlers (you can also open the manager from the Add rule to 
message handler dialog box). The Edit Message Handlers dialog 

box appears.

To edit an existing handler:

1 Choose an option to specify whether you want to edit the local 
runtime handler for the currently selected job, edit the project-
level message handler, or edit a specific message handler. If you 
want to edit a specific message handler, select the handler from 
the drop-down list. The settings for whichever handler you have 
chosen to edit appear in the grid.

2 Edit the grid as required. You can:
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– Choose a new Action for a particular message. Select a new 
action from the drop-down list. Possible Actions are:

Suppress from log. The message is not written to the job's 

log as it runs.

Promote to Warning. Promote an informational message to a 

warning message.

Demote to Informational. Demote a warning message to 

become an informational one.

– Delete a message. Select the message in the grid, right-click 
and choose Delete Row from the shortcut menu.

– Add a new message. Right-click in the grid and choose Insert 
Row from the shortcut menu. You can then type in details of 
the message you want to add to the handler.

When you are done with your edits, click Save and choose 

Save Message Handler to save the handler with its current 

name or Save Message Handler As to save it as a new handler.

To delete a handler:

1 Choose an option to specify whether you want to delete the local 
runtime handler for the currently selected job, delete the project-
level message handler, or delete a specific message handler. If 
you want to delete a specific message handler, select the handler 
from the drop-down list. The settings for whichever handler you 
have chosen to edit appear in the grid.

2 Click the Delete button.

To define a new handler:

1 Choose Edit chosen message handler and select (New) from 
the drop-down list. The grid clears, allowing new message rules to 
be added.

2 Type in the message ID for the first message you want to add to 
the handler.

3 Choose an Action from the drop-down list. Possible Actions are:

– Suppress from log. The message is not written to the job's 
log as it runs.

– Promote to Warning. Promote an informational message to a 
warning message.

– Demote to Informational. Demote a warning message to 
become an informational one.

4 Repeat this process until you have added all the required 
messages.
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5 When you have defined all the required messages for the handler, 
click Save and choose Save Message Handler As from the 
menu. A dialog box opens and prompts you for the name of the 
new handler.

6 Type in the name for your new message handler.
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This glossary contains terms that have a specific meaning in 

DataStage. 

Term Meaning

active stage A stage in a job that carries out processing. Only active stages can be 
monitored from a Monitor window. See Chapter 5.

data source A source for the data to be processed in a DataStage job, for example, a 
database, file, or device.

DataStage 
Administrator

The client program used for administering DataStage projects. See 
DataStage Administrator Guide.

DataStage Designer A graphical design program used to design and develop DataStage jobs. 
See DataStage Designer Guide.

DataStage Director A program used to run and monitor DataStage jobs.

DataStage Manager A program used to view and manage the contents of the Repository. See 
DataStage Manager Guide.

DataStage Server The DataStage component that links the DataStage client programs to the 
server engine.

developer The person designing and developing DataStage jobs.

job A program that defines how to extract, cleanse, transform, integrate, and 
load data into a target database. Jobs are designed and packaged by the 
developer, using the DataStage Designer. See also server job, parallel 
job, and mainframe job.

job batches A group of jobs that are run together as a sequence. See Chapter 4. 

job instance From the Director you can run multiple instances of the same job. See 
Chapter 3.

job log A file containing entries for events that occur during a job run. You view log 
entries from the Job Log view. See Chapter 6.

job parameter A variable included in the job design, for example, a file name or a 
password. A suitable value must be entered for the variable when the job is 
validated, scheduled, or run.

link A variable included in the job design, for example, a file name or a 
password. A suitable value must be entered for the variable when the job is 
validated, scheduled, or run. 
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mainframe job A DataStage job that is compiled and run on a mainframe computer by a 
mainframe software tool. See also job.

message handler Defines rules about how to handle messages generated when a parallel job 
is running. You can, for example, use one to specify that certain types of 
message should not be written to the log.

operator The person running, scheduling, and monitoring DataStage jobs.

parallel job A DataStage job that allows you to take advantage of parallel processing on 
SMP, MPP, and cluster systems.

project A collection of jobs and the components required to develop or run them. 
The level at which you enter DataStage from a client. DataStage projects 
must be licensed.

Repository A server area where projects and jobs are stored. The Repository also holds 
definitions for data, stages, and so on. The Repository is accessed through 
the DataStage Manager. See DataStage Manager Guide.

server engine The server software that holds, cleanses, and transforms the data during a 
DataStage job run.

server job A DataStage job that is compiled by the DataStage Designer, then run on a 
DataStage server from the Director. See also job.

stage A component that represents a data source, a processing step, or a data 
mart in a DataStage job. See also active stage.

Term Meaning
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